aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/meson.build')
-rw-r--r--drivers/meson.build25
1 files changed, 18 insertions, 7 deletions
diff --git a/drivers/meson.build b/drivers/meson.build
index b41a0f18..f94e2fe6 100644
--- a/drivers/meson.build
+++ b/drivers/meson.build
@@ -2,12 +2,19 @@
# Copyright(c) 2017 Intel Corporation
# Defines the order in which the drivers are buit.
-driver_classes = ['bus',
- 'mempool', # depends on bus.
- 'net', # depends on bus and mempool.
- 'crypto', # depenss on bus, mempool (net in future).
- 'event'] # depends on bus, mempool and net.
-
+driver_classes = ['common',
+ 'bus',
+ 'mempool', # depends on common and bus.
+ 'net', # depends on common, bus and mempool.
+ 'crypto', # depends on common, bus and mempool (net in future).
+ 'compress', # depends on common, bus, mempool.
+ 'event', # depends on common, bus, mempool and net.
+ 'raw'] # depends on common, bus, mempool, net and event.
+
+default_cflags = machine_args
+if cc.has_argument('-Wno-format-truncation')
+ default_cflags += '-Wno-format-truncation'
+endif
foreach class:driver_classes
drivers = []
std_deps = []
@@ -28,7 +35,7 @@ foreach class:driver_classes
allow_experimental_apis = false
sources = []
objs = []
- cflags = machine_args
+ cflags = default_cflags
includes = [include_directories(drv_path)]
# set up internal deps. Drivers can append/override as necessary
deps = std_deps
@@ -55,6 +62,10 @@ foreach class:driver_classes
shared_objs = []
static_objs = []
foreach d:deps
+ if not is_variable('shared_rte_' + d)
+ error('Missing dependency ' + d +
+ ' for driver ' + lib_name)
+ endif
shared_objs += [get_variable('shared_rte_' + d)]
static_objs += [get_variable('static_rte_' + d)]
endforeach