aboutsummaryrefslogtreecommitdiffstats
path: root/examples/ip_pipeline/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'examples/ip_pipeline/meson.build')
-rw-r--r--examples/ip_pipeline/meson.build36
1 files changed, 13 insertions, 23 deletions
diff --git a/examples/ip_pipeline/meson.build b/examples/ip_pipeline/meson.build
index 748c9ae0..a9f2ea44 100644
--- a/examples/ip_pipeline/meson.build
+++ b/examples/ip_pipeline/meson.build
@@ -1,35 +1,25 @@
# SPDX-License-Identifier: BSD-3-Clause
-# Copyright(c) 2017 Intel Corporation
+# Copyright(c) 2017-2018 Intel Corporation
# meson file, for building this example as part of a main DPDK build.
#
# To build this example as a standalone application with an already-installed
# DPDK instance, use 'make'
-deps += ['cfgfile', 'pipeline', 'bus_pci']
-includes += include_directories('pipeline')
+deps += ['pipeline', 'bus_pci']
+allow_experimental_apis = true
sources = files(
- 'config_check.c',
- 'config_parse.c',
- 'config_parse_tm.c',
- 'cpu_core_map.c',
- 'init.c',
+ 'action.c',
+ 'cli.c',
+ 'conn.c',
+ 'kni.c',
+ 'link.c',
'main.c',
+ 'mempool.c',
'parser.c',
+ 'pipeline.c',
+ 'swq.c',
+ 'tap.c',
'thread.c',
- 'thread_fe.c',
- 'pipeline/pipeline_common_be.c',
- 'pipeline/pipeline_common_fe.c',
- 'pipeline/pipeline_firewall_be.c',
- 'pipeline/pipeline_firewall.c',
- 'pipeline/pipeline_flow_actions_be.c',
- 'pipeline/pipeline_flow_actions.c',
- 'pipeline/pipeline_flow_classification_be.c',
- 'pipeline/pipeline_flow_classification.c',
- 'pipeline/pipeline_master_be.c',
- 'pipeline/pipeline_master.c',
- 'pipeline/pipeline_passthrough_be.c',
- 'pipeline/pipeline_passthrough.c',
- 'pipeline/pipeline_routing_be.c',
- 'pipeline/pipeline_routing.c',
+ 'tmgr.c'
)