aboutsummaryrefslogtreecommitdiffstats
path: root/examples/ipsec-secgw/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'examples/ipsec-secgw/meson.build')
-rw-r--r--examples/ipsec-secgw/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/examples/ipsec-secgw/meson.build b/examples/ipsec-secgw/meson.build
new file mode 100644
index 00000000..77d8b298
--- /dev/null
+++ b/examples/ipsec-secgw/meson.build
@@ -0,0 +1,14 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017 Intel Corporation
+
+# meson file, for building this example as part of a main DPDK build.
+#
+# To build this example as a standalone application with an already-installed
+# DPDK instance, use 'make'
+
+deps += ['security', 'lpm', 'acl', 'hash']
+allow_experimental_apis = true
+sources = files(
+ 'esp.c', 'ipsec.c', 'ipsec-secgw.c', 'parser.c',
+ 'rt.c', 'sa.c', 'sp4.c', 'sp6.c'
+)