aboutsummaryrefslogtreecommitdiffstats
path: root/examples/l2fwd-cat/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'examples/l2fwd-cat/meson.build')
-rw-r--r--examples/l2fwd-cat/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/examples/l2fwd-cat/meson.build b/examples/l2fwd-cat/meson.build
index b6deabc9..1234e7b5 100644
--- a/examples/l2fwd-cat/meson.build
+++ b/examples/l2fwd-cat/meson.build
@@ -6,7 +6,9 @@
# To build this example as a standalone application with an already-installed
# DPDK instance, use 'make'
-ext_deps += cc.find_library('pqos')
+pqos = cc.find_library('pqos', required: false)
+build = pqos.found()
+ext_deps += pqos
cflags += '-D_GNU_SOURCE'
cflags += '-I/usr/local/include' # assume pqos lib installed in /usr/local
sources = files(