aboutsummaryrefslogtreecommitdiffstats
path: root/examples/l3fwd-power/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'examples/l3fwd-power/meson.build')
-rw-r--r--examples/l3fwd-power/meson.build7
1 files changed, 5 insertions, 2 deletions
diff --git a/examples/l3fwd-power/meson.build b/examples/l3fwd-power/meson.build
index 61e8daa9..20c80543 100644
--- a/examples/l3fwd-power/meson.build
+++ b/examples/l3fwd-power/meson.build
@@ -1,12 +1,15 @@
# SPDX-License-Identifier: BSD-3-Clause
-# Copyright(c) 2017 Intel Corporation
+# Copyright(c) 2018 Intel Corporation
# meson file, for building this example as part of a main DPDK build.
#
# To build this example as a standalone application with an already-installed
# DPDK instance, use 'make'
+if host_machine.system() != 'linux'
+ build = false
+endif
deps += ['power', 'timer', 'lpm', 'hash']
sources = files(
- 'main.c'
+ 'main.c', 'perf_core.c'
)