aboutsummaryrefslogtreecommitdiffstats
path: root/examples/vhost/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'examples/vhost/meson.build')
-rw-r--r--examples/vhost/meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/vhost/meson.build b/examples/vhost/meson.build
index 3e6e6904..7b498076 100644
--- a/examples/vhost/meson.build
+++ b/examples/vhost/meson.build
@@ -6,7 +6,11 @@
# To build this example as a standalone application with an already-installed
# DPDK instance, use 'make'
+if host_machine.system() != 'linux'
+ build = false
+endif
deps += 'vhost'
+allow_experimental_apis = true
sources = files(
'main.c', 'virtio_net.c'
)