aboutsummaryrefslogtreecommitdiffstats
path: root/examples/vhost_crypto/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'examples/vhost_crypto/meson.build')
-rw-r--r--examples/vhost_crypto/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/examples/vhost_crypto/meson.build b/examples/vhost_crypto/meson.build
new file mode 100644
index 00000000..0f4876f0
--- /dev/null
+++ b/examples/vhost_crypto/meson.build
@@ -0,0 +1,14 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017-2018 Intel Corporation
+
+# meson file, for building this example as part of a main DPDK build.
+#
+# To build this example as a standalone application with an already-installed
+# DPDK instance, use 'make'
+
+allow_experimental_apis = true
+deps += ['vhost', 'cryptodev']
+cflags += ['-D_GNU_SOURCE','-D_FILE_OFFSET_BITS=64']
+sources = files(
+ 'main.c'
+)