aboutsummaryrefslogtreecommitdiffstats
path: root/lib/librte_hash/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'lib/librte_hash/meson.build')
-rw-r--r--lib/librte_hash/meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/lib/librte_hash/meson.build b/lib/librte_hash/meson.build
new file mode 100644
index 00000000..e139e1d7
--- /dev/null
+++ b/lib/librte_hash/meson.build
@@ -0,0 +1,17 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017 Intel Corporation
+
+version = 2
+headers = files('rte_cmp_arm64.h',
+ 'rte_cmp_x86.h',
+ 'rte_crc_arm64.h',
+ 'rte_cuckoo_hash.h',
+ 'rte_cuckoo_hash_x86.h',
+ 'rte_fbk_hash.h',
+ 'rte_hash_crc.h',
+ 'rte_hash.h',
+ 'rte_jhash.h',
+ 'rte_thash.h')
+
+sources = files('rte_cuckoo_hash.c', 'rte_fbk_hash.c')
+deps += ['ring']