aboutsummaryrefslogtreecommitdiffstats
path: root/lib/librte_lpm/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'lib/librte_lpm/meson.build')
-rw-r--r--lib/librte_lpm/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/lib/librte_lpm/meson.build b/lib/librte_lpm/meson.build
new file mode 100644
index 00000000..06784942
--- /dev/null
+++ b/lib/librte_lpm/meson.build
@@ -0,0 +1,9 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017 Intel Corporation
+
+version = 2
+sources = files('rte_lpm.c', 'rte_lpm6.c')
+headers = files('rte_lpm.h', 'rte_lpm6.h')
+# since header files have different names, we can install all vector headers
+# without worrying about which architecture we actually need
+headers += files('rte_lpm_altivec.h', 'rte_lpm_neon.h', 'rte_lpm_sse.h')