aboutsummaryrefslogtreecommitdiffstats
path: root/test/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/test/meson.build')
-rw-r--r--test/test/meson.build24
1 files changed, 22 insertions, 2 deletions
diff --git a/test/test/meson.build b/test/test/meson.build
index b1dd6eca..554e9945 100644
--- a/test/test/meson.build
+++ b/test/test/meson.build
@@ -33,15 +33,20 @@ test_sources = files('commands.c',
'test_efd.c',
'test_efd_perf.c',
'test_errno.c',
+ 'test_event_crypto_adapter.c',
+ 'test_event_eth_rx_adapter.c',
'test_event_ring.c',
+ 'test_event_eth_tx_adapter.c',
+ 'test_event_timer_adapter.c',
'test_eventdev.c',
'test_func_reentrancy.c',
'test_flow_classify.c',
'test_hash.c',
'test_hash_functions.c',
'test_hash_multiwriter.c',
+ 'test_hash_readwrite.c',
'test_hash_perf.c',
- 'test_hash_scaling.c',
+ 'test_hash_readwrite_lf.c',
'test_interrupts.c',
'test_kni.c',
'test_kvargs.c',
@@ -63,6 +68,7 @@ test_sources = files('commands.c',
'test_mempool_perf.c',
'test_memzone.c',
'test_meter.c',
+ 'test_metrics.c',
'test_mp_secondary.c',
'test_per_lcore.c',
'test_pmd_perf.c',
@@ -111,6 +117,7 @@ test_deps = ['acl',
'hash',
'lpm',
'member',
+ 'metrics',
'pipeline',
'port',
'reorder',
@@ -141,8 +148,10 @@ test_names = [
'cryptodev_sw_mvsam_autotest',
'cryptodev_dpaa2_sec_autotest',
'cryptodev_dpaa_sec_autotest',
+ 'cryptodev_octeontx_autotest',
'cycles_autotest',
'debug_autotest',
+ 'delay_us_sleep_autotest',
'devargs_autotest',
'distributor_autotest',
'distributor_perf_autotest',
@@ -151,17 +160,24 @@ test_names = [
'efd_autotest',
'efd_perf_autotest',
'errno_autotest',
+ 'event_crypto_adapter_autotest',
+ 'event_eth_rx_adapter_autotest',
+ 'event_eth_rx_intr_adapter_autotest',
'event_ring_autotest',
+ 'event_eth_tx_adapter_autotest',
+ 'event_timer_adapter_autotest',
'eventdev_common_autotest',
'eventdev_octeontx_autotest',
'eventdev_sw_autotest',
+ 'external_mem_autotest',
'func_reentrancy_autotest',
'flow_classify_autotest',
- 'hash_scaling_autotest',
'hash_autotest',
'hash_functions_autotest',
'hash_multiwriter_autotest',
'hash_perf_autotest',
+ 'hash_readwrite_autotest',
+ 'hash_readwrite_lf_autotest',
'interrupt_autotest',
'kni_autotest',
'kvargs_autotest',
@@ -183,6 +199,7 @@ test_names = [
'mempool_perf_autotest',
'memzone_autotest',
'meter_autotest',
+ 'metrics_autotest',
'multiprocess_autotest',
'per_lcore_autotest',
'pmd_perf_autotest',
@@ -242,6 +259,9 @@ if cc.has_argument('-Wno-format-truncation')
cflags += '-Wno-format-truncation'
endif
+# specify -D_GNU_SOURCE unconditionally
+default_cflags += '-D_GNU_SOURCE'
+
test_dep_objs = []
compress_test_dep = dependency('zlib', required: false)
if compress_test_dep.found()