summaryrefslogtreecommitdiffstats
path: root/app_example/func-test/file_transfer/CMakeLists.txt
diff options
context:
space:
mode:
authorcharan makkina <charan795m@gmail.com>2018-10-15 18:55:36 +0530
committercharan makkina <charan795m@gmail.com>2018-11-20 16:56:51 +0530
commitd4b0a17bcd1be6478523ccc0ff25c057ff40f511 (patch)
treee34f78b88047025d2c86d5bdd015efb8faecfe3f /app_example/func-test/file_transfer/CMakeLists.txt
parentaf0587ee6e44e9057ff6047a00fcd9015df1f5a1 (diff)
Test:Test cases for file transfer and fork for both kernel and lwip_stacks.
Change-Id: I04744d4d12e403f9df9f522953b8f7b8b30246d8 Signed-off-by: charan makkina <charan795m@gmail.com>
Diffstat (limited to 'app_example/func-test/file_transfer/CMakeLists.txt')
-rw-r--r--app_example/func-test/file_transfer/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/app_example/func-test/file_transfer/CMakeLists.txt b/app_example/func-test/file_transfer/CMakeLists.txt
new file mode 100644
index 0000000..408fc7a
--- /dev/null
+++ b/app_example/func-test/file_transfer/CMakeLists.txt
@@ -0,0 +1,32 @@
+#########################################################################
+#
+# Copyright (c) 2018 Huawei Technologies Co.,Ltd.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#########################################################################
+SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -O2 -g -fPIC -m64 -mssse3 -std=gnu89")
+
+LINK_DIRECTORIES(${LIB_PATH_SHARED} ${LIB_PATH_STATIC})
+
+ADD_EXECUTABLE(vc_serv_file server_filetrans.c)
+ADD_DEPENDENCIES(vc_serv_file nStackAPI)
+TARGET_LINK_LIBRARIES(vc_serv_file libnStackAPI.so -lpthread -lrt)
+
+ADD_EXECUTABLE(vc_cli_file client_filetrans.c)
+ADD_DEPENDENCIES(vc_cli_file nStackAPI)
+TARGET_LINK_LIBRARIES(vc_cli_file libnStackAPI.so -lpthread -lrt)
+
+ADD_EXECUTABLE(kc_serv_file server_filetrans.c)
+TARGET_LINK_LIBRARIES(kc_serv_file pthread)
+
+ADD_EXECUTABLE(kc_cli_file client_filetrans.c)
+TARGET_LINK_LIBRARIES(kc_cli_file pthread) \ No newline at end of file