summaryrefslogtreecommitdiffstats
path: root/app_example/perf-test/CMakeLists.txt
diff options
context:
space:
mode:
authorsharath reddy <bs.reddy@huawei.com>2019-06-04 11:53:49 +0530
committersharath reddy <bs.reddy@huawei.com>2019-06-04 20:38:30 +0530
commit2a42ad20b9730706ad371ae3787d4597c4e42276 (patch)
treefa01cd312586ea007468e7233f94c0ce53d75873 /app_example/perf-test/CMakeLists.txt
parenta826fe833d3f2a8fe2673fa05811fe1a22baf045 (diff)
Feature: 19.04 part-2DMM-2
Change-Id: I0b52a6bb67c25c7955d58e29eb81a3cc9efea9e9 Signed-off-by: sharath reddy <bs.reddy@huawei.com>
Diffstat (limited to 'app_example/perf-test/CMakeLists.txt')
-rw-r--r--app_example/perf-test/CMakeLists.txt47
1 files changed, 47 insertions, 0 deletions
diff --git a/app_example/perf-test/CMakeLists.txt b/app_example/perf-test/CMakeLists.txt
new file mode 100644
index 0000000..7f05b84
--- /dev/null
+++ b/app_example/perf-test/CMakeLists.txt
@@ -0,0 +1,47 @@
+#########################################################################
+#
+# Copyright (c) 2018 Huawei Technologies Co.,Ltd.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#########################################################################
+SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -O2 -g -fPIC -m64 -mssse3 -std=gnu89")
+
+LINK_DIRECTORIES(${LIB_PATH_SHARED} ${LIB_PATH_STATIC})
+
+ADD_EXECUTABLE(vc_common multi_tcp_common_app_Cli.c)
+ADD_DEPENDENCIES(vc_common nStackAPI)
+TARGET_LINK_LIBRARIES(vc_common libnStackAPI.so -lpthread -lrt)
+
+ADD_EXECUTABLE(vs_epoll multi_tcp_epoll_app_Ser.c)
+ADD_DEPENDENCIES(vs_epoll nStackAPI)
+TARGET_LINK_LIBRARIES(vs_epoll libnStackAPI.so -lpthread -lrt)
+
+ADD_EXECUTABLE(vs_select multi_tcp_select_app_Ser.c)
+ADD_DEPENDENCIES(vs_select nStackAPI)
+TARGET_LINK_LIBRARIES(vs_select libnStackAPI.so -lpthread -lrt)
+
+ADD_EXECUTABLE(kc_common multi_tcp_common_app_Cli.c)
+TARGET_LINK_LIBRARIES(kc_common pthread)
+
+ADD_EXECUTABLE(ks_epoll multi_tcp_epoll_app_Ser.c)
+TARGET_LINK_LIBRARIES(ks_epoll pthread)
+
+ADD_EXECUTABLE(ks_select multi_tcp_select_app_Ser.c)
+TARGET_LINK_LIBRARIES(ks_select pthread)
+
+ADD_EXECUTABLE(vs_common multi_tcp_common_Ser.c)
+ADD_DEPENDENCIES(vs_common nStackAPI)
+TARGET_LINK_LIBRARIES(vs_common libnStackAPI.so -lpthread -lrt)
+
+ADD_EXECUTABLE(ks_common multi_tcp_common_Ser.c)
+TARGET_LINK_LIBRARIES(ks_common pthread)
+