summaryrefslogtreecommitdiffstats
path: root/app_example/perf-test/CMakeLists.txt
diff options
context:
space:
mode:
authorzqysara <zhangqiyu1@huawei.com>2018-07-20 15:32:22 +0800
committerZhang Qiyu <zhangqiyu1@huawei.com>2018-08-01 09:50:00 +0000
commit480f7932d491cfcddfd78397fc8f3997436d4a8b (patch)
treee91ce7d56a4cabab85d7bf802408361ae39255b2 /app_example/perf-test/CMakeLists.txt
parentf168f527bb9587ec398a2fd3d98615188b0dfab1 (diff)
Feat: implement send/recv in ks_common.c and vs_common.c
An file can test only the send/receive API, exclude epoll and select; the app named ks_common and vs_common; Change-Id: Id1c751f78644dad4f00e4df0368fa7094af394fe Signed-off-by: zqysara <zhangqiyu1@huawei.com>
Diffstat (limited to 'app_example/perf-test/CMakeLists.txt')
-rw-r--r--app_example/perf-test/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/app_example/perf-test/CMakeLists.txt b/app_example/perf-test/CMakeLists.txt
index 686cf4f..7f05b84 100644
--- a/app_example/perf-test/CMakeLists.txt
+++ b/app_example/perf-test/CMakeLists.txt
@@ -37,3 +37,11 @@ TARGET_LINK_LIBRARIES(ks_epoll pthread)
ADD_EXECUTABLE(ks_select multi_tcp_select_app_Ser.c)
TARGET_LINK_LIBRARIES(ks_select pthread)
+
+ADD_EXECUTABLE(vs_common multi_tcp_common_Ser.c)
+ADD_DEPENDENCIES(vs_common nStackAPI)
+TARGET_LINK_LIBRARIES(vs_common libnStackAPI.so -lpthread -lrt)
+
+ADD_EXECUTABLE(ks_common multi_tcp_common_Ser.c)
+TARGET_LINK_LIBRARIES(ks_common pthread)
+