summaryrefslogtreecommitdiffstats
path: root/app_example/perf-test/CMakeLists.txt
diff options
context:
space:
mode:
authorqchang <qing.chang1@huawei.com>2018-03-08 17:39:22 -0800
committerqchang <qing.chang1@huawei.com>2018-03-08 17:39:22 -0800
commit697ade6190b23c80e7f60963983786e679759393 (patch)
treedd9782d1e936b8342163b26795e23571d4b1b415 /app_example/perf-test/CMakeLists.txt
parent71a4e2f34afa8018426f0e830050e50a1de6d375 (diff)
dmm initial commit
Change-Id: I049ee277cf4efdb83f9c2ac439365fcd421c159b Signed-off-by: qchang <qing.chang1@huawei.com>
Diffstat (limited to 'app_example/perf-test/CMakeLists.txt')
-rw-r--r--app_example/perf-test/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/app_example/perf-test/CMakeLists.txt b/app_example/perf-test/CMakeLists.txt
new file mode 100644
index 0000000..a22f071
--- /dev/null
+++ b/app_example/perf-test/CMakeLists.txt
@@ -0,0 +1,39 @@
+#########################################################################
+#
+# Copyright (c) 2018 Huawei Technologies Co.,Ltd.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#########################################################################
+
+LINK_DIRECTORIES(${LIB_PATH_SHARED} ${LIB_PATH_STATIC})
+
+ADD_EXECUTABLE(vc_epoll multi_tcp_epoll_app_Cli.c)
+ADD_DEPENDENCIES(vc_epoll nStackAPI)
+TARGET_LINK_LIBRARIES(vc_epoll libnStackAPI.so -Wl,-rpath=. -lpthread -lrt)
+
+ADD_EXECUTABLE(vs_epoll multi_tcp_epoll_app_Ser.c)
+ADD_DEPENDENCIES(vs_epoll nStackAPI)
+TARGET_LINK_LIBRARIES(vs_epoll libnStackAPI.so -Wl,-rpath=. -lpthread -lrt)
+
+ADD_EXECUTABLE(kc_epoll multi_tcp_epoll_app_Cli.c)
+TARGET_LINK_LIBRARIES(kc_epoll pthread)
+
+ADD_EXECUTABLE(ks_epoll multi_tcp_epoll_app_Ser.c)
+TARGET_LINK_LIBRARIES(ks_epoll pthread)
+
+#ADD_EXECUTABLE(vs_no_epoll multi_tcp_no_epoll_Ser.c)
+#ADD_DEPENDENCIES(vs_no_epoll nStackAPI)
+#TARGET_LINK_LIBRARIES(vs_no_epoll libnStackAPI.so -Wl,-rpath=. -lpthread -lrt)
+
+#ADD_EXECUTABLE(ks_no_epoll multi_tcp_no_epoll_Ser.c)
+#TARGET_LINK_LIBRARIES(ks_no_epoll pthread)
+