summaryrefslogtreecommitdiffstats
path: root/src/framework/init/CMakeLists.txt
diff options
context:
space:
mode:
authorqchang <qing.chang1@huawei.com>2018-03-08 17:39:22 -0800
committerqchang <qing.chang1@huawei.com>2018-03-08 17:39:22 -0800
commit697ade6190b23c80e7f60963983786e679759393 (patch)
treedd9782d1e936b8342163b26795e23571d4b1b415 /src/framework/init/CMakeLists.txt
parent71a4e2f34afa8018426f0e830050e50a1de6d375 (diff)
dmm initial commit
Change-Id: I049ee277cf4efdb83f9c2ac439365fcd421c159b Signed-off-by: qchang <qing.chang1@huawei.com>
Diffstat (limited to 'src/framework/init/CMakeLists.txt')
-rw-r--r--src/framework/init/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/framework/init/CMakeLists.txt b/src/framework/init/CMakeLists.txt
new file mode 100644
index 0000000..ff8d4d2
--- /dev/null
+++ b/src/framework/init/CMakeLists.txt
@@ -0,0 +1,24 @@
+#########################################################################
+#
+# Copyright (c) 2018 Huawei Technologies Co.,Ltd.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#########################################################################
+
+SET(LIBSBR_SRC fw_init.c fw_module.c)
+
+SET(COMM_CONFIG ${PROJECT_SOURCE_DIR}/src/framework/common/base/include/common_sys_config.h)
+ADD_DEFINITIONS(-fPIC -mssse3)
+ADD_DEFINITIONS(-include ${COMM_CONFIG})
+
+ADD_LIBRARY(nStackfwinit static ${LIBSBR_SRC})
+