summaryrefslogtreecommitdiffstats
path: root/stacks/lwip_stack/src/alarm/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'stacks/lwip_stack/src/alarm/CMakeLists.txt')
-rw-r--r--stacks/lwip_stack/src/alarm/CMakeLists.txt34
1 files changed, 0 insertions, 34 deletions
diff --git a/stacks/lwip_stack/src/alarm/CMakeLists.txt b/stacks/lwip_stack/src/alarm/CMakeLists.txt
deleted file mode 100644
index 3de07b0..0000000
--- a/stacks/lwip_stack/src/alarm/CMakeLists.txt
+++ /dev/null
@@ -1,34 +0,0 @@
-#########################################################################
-#
-# Copyright (c) 2018 Huawei Technologies Co.,Ltd.
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at:
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-#########################################################################
-
-FILE(GLOB_RECURSE ALARM *.c)
-
-LINK_LIBRARIES(m dl rt dmm_api)
-if(WITH_SECUREC_LIB)
-INCLUDE_DIRECTORIES(
- ./
- ${JSON_C_SRC}
- ${SECUREC_SRC}
- ${CMAKE_CURRENT_LIST_DIR}/../include/
-)
-else()
-INCLUDE_DIRECTORIES(
- ./
- ${JSON_C_SRC}
- ${CMAKE_CURRENT_LIST_DIR}/../include/
-)
-endif()
-ADD_LIBRARY(nStackAlarm STATIC ${ALARM})