aboutsummaryrefslogtreecommitdiffstats
path: root/stacks/lwip_stack/src/mem_mgr/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'stacks/lwip_stack/src/mem_mgr/CMakeLists.txt')
-rw-r--r--stacks/lwip_stack/src/mem_mgr/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/stacks/lwip_stack/src/mem_mgr/CMakeLists.txt b/stacks/lwip_stack/src/mem_mgr/CMakeLists.txt
new file mode 100644
index 0000000..feeba99
--- /dev/null
+++ b/stacks/lwip_stack/src/mem_mgr/CMakeLists.txt
@@ -0,0 +1,36 @@
+#########################################################################
+#
+# Copyright (c) 2018 Huawei Technologies Co.,Ltd.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#########################################################################
+
+INCLUDE_DIRECTORIES(include nsfw_nshmem nsfw_shmem ps_mem)
+
+if(WITH_HAL_LIB)
+else()
+ SET(PAL_H_DIRECTORIES "/usr/include/dpdk/")
+ INCLUDE_DIRECTORIES(${PAL_H_DIRECTORIES})
+# SET(PAL_BITWIDE_ADJUST ${PROJECT_SOURCE_DIR}/src/include/common_pal_bitwide_adjust.h)
+# ADD_DEFINITIONS(-include ${PAL_BITWIDE_ADJUST})
+endif()
+
+FILE(GLOB_RECURSE MEM_MGR_SRC *.c)
+
+#LINK_LIBRARIES(m dl rt dmm_api)
+
+if(WITH_SECUREC_LIB)
+INCLUDE_DIRECTORIES(
+ ${SECUREC_SRC}
+)
+endif()
+ADD_LIBRARY(mem_mgr STATIC ${MEM_MGR_SRC})