summaryrefslogtreecommitdiffstats
path: root/packaging/deb/debian/rules
diff options
context:
space:
mode:
authorMaros Marsalek <mmarsale@cisco.com>2016-08-22 12:59:37 +0200
committerMaros Marsalek <mmarsale@cisco.com>2016-08-22 14:28:54 +0000
commit4ae1834e89a1b43d0d54b817397208232f5835a0 (patch)
tree2c684480edf47c889cc0918cb5bc01142329049a /packaging/deb/debian/rules
parentb47d696bf3bd5640f44b43cdb12688dc19a0b5d7 (diff)
Honeycomb deb packaging
Change-Id: I6f029ef9236cbd3f7f20fd8e44f83b15cdedc5db Signed-off-by: Maros Marsalek <mmarsale@cisco.com>
Diffstat (limited to 'packaging/deb/debian/rules')
-rwxr-xr-xpackaging/deb/debian/rules32
1 files changed, 32 insertions, 0 deletions
diff --git a/packaging/deb/debian/rules b/packaging/deb/debian/rules
new file mode 100755
index 000000000..5c1cebc20
--- /dev/null
+++ b/packaging/deb/debian/rules
@@ -0,0 +1,32 @@
+#!/usr/bin/make -f
+# See debhelper(7) (uncomment to enable)
+# output every command that modifies files on the build system.
+#export DH_VERBOSE = 1
+
+# see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/default.mk
+
+# see FEATURE AREAS in dpkg-buildflags(1)
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+# see ENVIRONMENT in dpkg-buildflags(1)
+# package maintainers to append CFLAGS
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+# package maintainers to append LDFLAGS
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+
+# main packaging script based on dh7 syntax
+%:
+ dh $@
+
+# dh_make generated override targets
+# This is example for Cmake (See https://bugs.debian.org/641051 )
+#override_dh_auto_configure:
+# dh_auto_configure -- \
+# -DCMAKE_LIBRARY_PATH=$(DEB_HOST_MULTIARCH)
+
+
+
+