aboutsummaryrefslogtreecommitdiffstats
path: root/nsh-plugin/Makefile.am
diff options
context:
space:
mode:
authorVengada <venggovi@cisco.com>2017-03-13 23:43:58 -0700
committerVengada <venggovi@cisco.com>2017-03-14 23:20:32 -0700
commitf126e1c375fb63ba6ae8121dce3ea86bc6cf1809 (patch)
treee790a4586309937f52f265650992c0e63ab7c823 /nsh-plugin/Makefile.am
parenta865240bfc157e06699319e39251e3653ca205f5 (diff)
Add support for iOAM (sub-TLV) over NSH-MD2. iOAM trace
records are carried as MD2 TLV data. Change-Id: Id6fe6c961aa3879df5ae476f13b0e39bcc6c0dfe Signed-off-by: Vengada <venggovi@cisco.com>
Diffstat (limited to 'nsh-plugin/Makefile.am')
-rw-r--r--nsh-plugin/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/nsh-plugin/Makefile.am b/nsh-plugin/Makefile.am
index ffbfaa3..2da0460 100644
--- a/nsh-plugin/Makefile.am
+++ b/nsh-plugin/Makefile.am
@@ -22,7 +22,12 @@ CPPFLAGS += -DDEBUG -g
lib_LTLIBRARIES = nsh_plugin.la nsh_test_plugin.la
nsh_plugin_la_SOURCES = nsh/nsh.c \
- vpp-api/nsh.api.h
+ vpp-api/nsh.api.h \
+ nsh-md2-ioam/nsh_md2_ioam.c \
+ nsh-md2-ioam/nsh_md2_ioam_trace.c \
+ nsh-md2-ioam/md2_ioam_transit.c \
+ nsh-md2-ioam/nsh_md2_ioam_api.c
+
nsh_plugin_la_LDFLAGS = -module
BUILT_SOURCES = vpp-api/nsh.api.h