aboutsummaryrefslogtreecommitdiffstats
path: root/nsh-plugin/packaging/deb/debian/rules
diff options
context:
space:
mode:
authorEd Warnicke <hagbard@gmail.com>2016-09-16 00:56:06 +0000
committerEd Warnicke <eaw@cisco.com>2016-10-04 11:26:38 -0700
commitd65ee3a8a3e7f6fccea9f682b4171c1ca1228f5e (patch)
tree81bc3e7817bb923e80ec8fb68df1c3a2f317f7d0 /nsh-plugin/packaging/deb/debian/rules
parent24bb3c191a66d20624d550f9ea392f2873199e88 (diff)
nsh-plugin deb packaging
Change-Id: I100f14fe2bc215beab8635cd987423599f15aaa0 Signed-off-by: Ed Warnicke <hagbard@gmail.com>
Diffstat (limited to 'nsh-plugin/packaging/deb/debian/rules')
-rwxr-xr-xnsh-plugin/packaging/deb/debian/rules27
1 files changed, 27 insertions, 0 deletions
diff --git a/nsh-plugin/packaging/deb/debian/rules b/nsh-plugin/packaging/deb/debian/rules
new file mode 100755
index 0000000..6d11aed
--- /dev/null
+++ b/nsh-plugin/packaging/deb/debian/rules
@@ -0,0 +1,27 @@
+#!/usr/bin/make -f
+# See debhelper(7) (uncomment to enable)
+# output every command that modifies files on the build system.
+DH_VERBOSE = 1
+
+# see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/default.mk
+
+# see FEATURE AREAS in dpkg-buildflags(1)
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+# see ENVIRONMENT in dpkg-buildflags(1)
+# package maintainers to append CFLAGS
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+# package maintainers to append LDFLAGS
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+# main packaging script based on dh7 syntax
+%:
+ dh $@ --with dkms --with systemd
+
+override_dh_install:
+ dh_install --exclude .git
+
+override_dh_strip:
+ dh_strip --dbg-package=vpp-nsh-plugin-dbg