aboutsummaryrefslogtreecommitdiffstats
path: root/nsh-plugin/packaging/deb/debian
diff options
context:
space:
mode:
Diffstat (limited to 'nsh-plugin/packaging/deb/debian')
-rw-r--r--nsh-plugin/packaging/deb/debian/compat1
-rw-r--r--nsh-plugin/packaging/deb/debian/control21
-rw-r--r--nsh-plugin/packaging/deb/debian/copyright9
-rwxr-xr-xnsh-plugin/packaging/deb/debian/rules27
4 files changed, 58 insertions, 0 deletions
diff --git a/nsh-plugin/packaging/deb/debian/compat b/nsh-plugin/packaging/deb/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/nsh-plugin/packaging/deb/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/nsh-plugin/packaging/deb/debian/control b/nsh-plugin/packaging/deb/debian/control
new file mode 100644
index 0000000..5ae4910
--- /dev/null
+++ b/nsh-plugin/packaging/deb/debian/control
@@ -0,0 +1,21 @@
+Source: vpp-nsh-plugin
+Section: net
+Priority: extra
+Maintainer: fd.io nsh-plugin for vpp
+Build-Depends: debhelper (>= 9), dkms, dh-systemd
+Standards-Version: 3.9.4
+
+Package: vpp-nsh-plugin
+Architecture: any
+Depends: vpp, ${shlibs:Depends}, ${misc:Depends}
+Description: fd.io nsh-plugin for vpp
+
+Package: vpp-nsh-plugin-dev
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: fd.io nsh-plugin for vpp api headers
+
+Package: vpp-nsh-plugin-dbg
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: fd.io nsh-plugin for vpp--debug symbols \ No newline at end of file
diff --git a/nsh-plugin/packaging/deb/debian/copyright b/nsh-plugin/packaging/deb/debian/copyright
new file mode 100644
index 0000000..f9775c1
--- /dev/null
+++ b/nsh-plugin/packaging/deb/debian/copyright
@@ -0,0 +1,9 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: optional.
+Upstream-Contact: optional.
+Source: optional.
+Disclaimer: optional.
+Comment: optional.
+License: Apache-2.0
+Copyright: 2015 Cisco and/or its affiliates and others.
+
diff --git a/nsh-plugin/packaging/deb/debian/rules b/nsh-plugin/packaging/deb/debian/rules
new file mode 100755
index 0000000..6d11aed
--- /dev/null
+++ b/nsh-plugin/packaging/deb/debian/rules
@@ -0,0 +1,27 @@
+#!/usr/bin/make -f
+# See debhelper(7) (uncomment to enable)
+# output every command that modifies files on the build system.
+DH_VERBOSE = 1
+
+# see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/default.mk
+
+# see FEATURE AREAS in dpkg-buildflags(1)
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+# see ENVIRONMENT in dpkg-buildflags(1)
+# package maintainers to append CFLAGS
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+# package maintainers to append LDFLAGS
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+# main packaging script based on dh7 syntax
+%:
+ dh $@ --with dkms --with systemd
+
+override_dh_install:
+ dh_install --exclude .git
+
+override_dh_strip:
+ dh_strip --dbg-package=vpp-nsh-plugin-dbg