aboutsummaryrefslogtreecommitdiffstats
path: root/build-data/packages/vpp.mk
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2016-04-01 12:35:17 +0200
committerGerrit Code Review <gerrit@fd.io>2016-04-01 15:22:15 +0000
commit28e3db9dd617324a3196f369788d62cc72b5903b (patch)
tree269e5356bf01e5565d7ac2006778dbad1be5edad /build-data/packages/vpp.mk
parentaa04a0ff8ee9aa7779b30e936f7fe1304c613d57 (diff)
Add options to link with external DPDK tree
By uncommenting following lines in the build-data/platforms/vpp.mk VPP links nicely with packaged DPDK 2.2 distributed with Ubuntu 16.04 LTS. vpp_uses_external_dpdk = yes vpp_dpdk_inc_dir = /usr/include/dpdk vpp_dpdk_lib_dir = /usr/lib vpp_dpdk_shared_lib = yes Change-Id: Id5b7d95bac6aa60341933b92e86d949a9abf1a5d Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'build-data/packages/vpp.mk')
-rw-r--r--build-data/packages/vpp.mk11
1 files changed, 10 insertions, 1 deletions
diff --git a/build-data/packages/vpp.mk b/build-data/packages/vpp.mk
index 9ccf6901..f96235f4 100644
--- a/build-data/packages/vpp.mk
+++ b/build-data/packages/vpp.mk
@@ -6,7 +6,11 @@ vpp_configure_depend = \
vnet-install \
#
-vpp_configure_args =
+ifeq ($($(PLATFORM)_dpdk_shared_lib),yes)
+vpp_configure_args = --enable-dpdk-shared
+else
+vpp_configure_args =
+endif
# Platform dependent configure flags
vpp_configure_args += $(vpp_configure_args_$(PLATFORM))
@@ -29,7 +33,12 @@ vpp_LDFLAGS = $(call installed_libs_fn, \
vnet)
ifneq ($($(PLATFORM)_uses_dpdk),no)
+ifeq ($($(PLATFORM)_uses_external_dpdk),yes)
+vpp_CPPFLAGS += -I$($(PLATFORM)_dpdk_inc_dir)
+vpp_LDFLAGS += -L$($(PLATFORM)_dpdk_lib_dir)
+else
vpp_configure_depend += dpdk-install
vpp_CPPFLAGS += $(call installed_includes_fn, dpdk)
vpp_LDFLAGS += $(call installed_libs_fn, dpdk)
endif
+endif