aboutsummaryrefslogtreecommitdiffstats
path: root/perftool/Makefile.am
diff options
context:
space:
mode:
authorDave Barach <dave@barachs.net>2016-02-11 19:28:19 -0500
committerGerrit Code Review <gerrit@fd.io>2016-02-12 01:30:48 +0000
commit52642c3c535128cb96489fed45327bdd55953397 (patch)
treece6e2cc9f505fbf04acbc9109adb4c204fb96c8c /perftool/Makefile.am
parent3640d537e1c1ea7670b98f0aaf27a48c08984893 (diff)
Performance tools, initial check-in
Change-Id: I9fb4f4babecbe02d171f38c4d089634e90141937 Signed-off-by: Dave Barach <dave@barachs.net>
Diffstat (limited to 'perftool/Makefile.am')
-rw-r--r--perftool/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/perftool/Makefile.am b/perftool/Makefile.am
new file mode 100644
index 00000000..ac652aa6
--- /dev/null
+++ b/perftool/Makefile.am
@@ -0,0 +1,44 @@
+# Copyright (c) 2016 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+AUTOMAKE_OPTIONS = foreign
+AM_CFLAGS = -Wall
+
+bin_PROGRAMS = c2cpel cpelatency cpeldump cpelinreg cpelstate
+
+lib_LTLIBRARIES = libcperf.la
+
+libcperf_la_SOURCES = delsvec.c linreg.c props.c cpel_util.c
+
+TOOL_LIBS = libcperf.la -lvppinfra -lm
+
+c2cpel_SOURCE = c2cpel.c
+c2cpel_LDADD = $(TOOL_LIBS)
+
+cpelatency_SOURCE = cpelatency.c
+cpelatency_LDADD = $(TOOL_LIBS)
+
+cpeldump_SOURCE = cpeldump.c
+cpeldump_LDADD = $(TOOL_LIBS)
+
+cpelinreg_SOURCE = cpelinreg.c
+cpelinreg_LDADD = $(TOOL_LIBS)
+
+cpelstate_SOURCE = cpelstate.c
+cpelstate_LDADD = $(TOOL_LIBS)
+
+
+
+
+
+