aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRadu Nicolau <radu.nicolau@intel.com>2017-02-20 12:27:02 +0000
committerDamjan Marion <dmarion.lists@gmail.com>2017-02-21 22:21:57 +0000
commit2e3677bb2085d4992f74156bdff8fe050ac9de24 (patch)
tree403ce371133cbdf0459a93c528ba4c481d1c1719 /src/Makefile.am
parent770e89e6b916319eedd91c6edf16f0d7e89f556c (diff)
cryptodev: Automatically download and build ISA-L Crypto library
Change-Id: I5454053461e6fb98e7f58f9562efde3590bb7cb5 Signed-off-by: Radu Nicolau <radu.nicolau@intel.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a0e62dbd..08feb29a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -49,7 +49,7 @@ else
DPDK_LD_FLAGS = -Wl,--whole-archive,-l:libdpdk.a,--no-whole-archive,-lm,-ldl
endif
if WITH_DPDK_CRYPTO_SW
-DPDK_LD_ADD = -lIPSec_MB
+DPDK_LD_ADD = -lIPSec_MB -lisal_crypto
endif
if WITH_DPDK_MLX5_PMD
DPDK_LD_FLAGS += -libverbs -lmlx5 -lnuma