aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2017-02-28 19:22:22 +0100
committerDave Barach <openvpp@barachs.net>2017-03-01 22:06:31 +0000
commitc3a814be9dc769be942ff8029c7b6eccd4b3af05 (patch)
treedd152b3e92281ab52f806ed2ad237c9fb0607e8b /src/Makefile.am
parentf71ef1dddfc7cf34944c510b85bec074f431bb12 (diff)
dpdk: be a plugin
Change-Id: I238258cdeb77035adc5e88903d824593d0a1da90 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am21
1 files changed, 0 insertions, 21 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 641707ed..5daaa48e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -39,27 +39,6 @@ install-data-local:
echo "Command list built, Time taken: $$GREP_TIME"
###############################################################################
-# DPDK
-###############################################################################
-
-if WITH_DPDK
-if ENABLE_DPDK_SHARED
-DPDK_LD_FLAGS = -Wl,--whole-archive,-ldpdk,--no-whole-archive
-else
-DPDK_LD_FLAGS = -Wl,--whole-archive,-l:libdpdk.a,--no-whole-archive,-lm,-ldl
-endif
-if WITH_DPDK_CRYPTO_SW
-DPDK_LD_ADD = -lIPSec_MB -lisal_crypto
-endif
-if WITH_DPDK_MLX5_PMD
-DPDK_LD_FLAGS += -libverbs -lmlx5 -lnuma
-endif
-else
-DPDK_LD_FLAGS =
-DPDK_LD_ADD =
-endif
-
-###############################################################################
# Components
###############################################################################