aboutsummaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2016-12-28 17:51:56 +0100
committerDave Barach <openvpp@barachs.net>2017-01-03 15:14:49 +0000
commit0be5ec304d2d4cfc6faecbb519ef165d9ab5d34e (patch)
tree385572e3c10c18a8a4fc347216946c52805a978f /src/configure.ac
parent78c3ba4fcfb06b8656a24817e183492c6a4fb2b8 (diff)
Do not require external vppapigen when not cross-compiling
Change-Id: I80b8348ed4efd53d292c37a1ff69c13ee4741986 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 4ed55705..eb380d8b 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -11,6 +11,8 @@ AM_PROG_AS
AM_PROG_LIBTOOL
AC_PROG_YACC
+AM_CONDITIONAL([CROSSCOMPILE], [test "$cross_compiling" == "yes"])
+
###############################################################################
# Macros
###############################################################################
@@ -172,6 +174,20 @@ AM_COND_IF([ENABLE_G2],
PKG_CHECK_MODULES(g2, gtk+-2.0)
])
+# If cross-compiling, we need external vppapigen and we cannot continue without it
+# For native builds, we just set dependency on vpppaigen binary in top_builddir
+AM_COND_IF([CROSSCOMPILE],
+[
+ AC_PATH_PROG([VPPAPIGEN], [vppapigen], [no])
+ if test "$VPPAPIGEN" = "no"; then
+ AC_MSG_ERROR([Externaly built vppapigen is needed when cross-compiling...])
+ fi
+],[
+ VPPAPIGEN=\$\(top_builddir\)/vppapigen
+])
+AC_SUBST([VPPAPIGEN])
+
+
###############################################################################
# JAVA
###############################################################################