aboutsummaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorSachin Saxena <sachin.saxena@nxp.com>2017-06-15 14:34:30 +0530
committersrsurend <srsurend@cisco.com>2017-07-03 06:09:53 -0400
commit704381d7bac04215ef270359f34658856c00d9a0 (patch)
tree3175cbb46106deb423d242f2be61c74968cda2d0 /src/configure.ac
parent8e60f32c576095fe44b904a9d0a99f5da2c081ab (diff)
Introducing ODP plugin node
Change-Id: I364fa14ade5282ec828662894041f9cc784ace7c Signed-off-by: srsurend <srsurend@cisco.com> Signed-off-by: sachin saxena <sachin.saxena@nxp.com>
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 173b3153..d1f8b9fa 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -104,13 +104,20 @@ WITH_ARG(dpdk_mlx5_pmd, [Use DPDK with mlx5 PMD])
WITHOUT_ARG(libssl, [Disable libssl])
WITHOUT_ARG(apicli, [Disable binary api CLI])
+AC_ARG_WITH(odplib,
+ AC_HELP_STRING([--with-odplib],[Use odplib]),
+ [with_odplib=1],
+ [with_odplib=0])
+
+AM_CONDITIONAL(WITH_ODPLIB, test $with_odplib = 1)
+
AC_ARG_WITH(unix,
AC_HELP_STRING([--with-unix],[Compile unix version of clib]),
[],
[case $host_os in
darwin* | linux*) with_unix=yes;;
*) with_unix=no;;
- esac])
+ esac])
AM_CONDITIONAL(WITH_UNIX, test "$with_unix" = "yes")
@@ -155,6 +162,8 @@ PLUGIN_ENABLED(lb)
PLUGIN_ENABLED(memif)
PLUGIN_ENABLED(sixrd)
PLUGIN_ENABLED(snat)
+AM_COND_IF([WITH_ODPLIB],
+[PLUGIN_ENABLED(odp)],[PLUGIN_DISABLED(odp)])
###############################################################################
# Dependency checks