aboutsummaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2017-01-16 22:06:10 +0100
committerFlorin Coras <florin.coras@gmail.com>2017-01-16 23:19:46 +0000
commita9a951f8e5ed6e172fbfbdbb6cb690c67fa2f715 (patch)
tree1a976cda2a242e013101124b9ed686a2811ae9a1 /src/configure.ac
parent597d3c4121b4dd557328c11debb42927a45d52fb (diff)
Add --without-libssl configure parameter
This replaces --without-ipsec and --without-ipv6sr and allows other parts of the code to be disabled if libssl is not available. Change-Id: Id97ff3685a7924d7f86622952e0405d94ceb5957 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/src/configure.ac b/src/configure.ac
index eb380d8b..b2234448 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -101,8 +101,7 @@ WITH_ARG(dpdk_crypto, [Use DPDK cryptodev])
WITH_ARG(dpdk_mlx5_pmd, [Use DPDK with mlx5 PMD])
# --without-X
-WITHOUT_ARG(ipsec, [Disable IPSec])
-WITHOUT_ARG(ipv6sr, [Disable IPv6 SR])
+WITHOUT_ARG(libssl, [Disable libssl])
WITHOUT_ARG(apicli, [Disable binary api CLI])
AC_ARG_WITH(unix,
@@ -133,8 +132,7 @@ AC_SUBST(APICLI, [-DVPP_API_TEST_BUILTIN=${n_with_apicli}])
AC_DEFINE_UNQUOTED(DPDK, [${n_with_dpdk}])
AC_DEFINE_UNQUOTED(DPDK_SHARED_LIB, [${n_enable_dpdk_shared}])
AC_DEFINE_UNQUOTED(DPDK_CRYPTO, [${n_with_dpdk_crypto}])
-AC_DEFINE_UNQUOTED(IPSEC, [${n_with_ipsec}])
-AC_DEFINE_UNQUOTED(IPV6SR, [${n_with_ipv6sr}])
+AC_DEFINE_UNQUOTED(WITH_LIBSSL, [${n_with_libssl}])
# Silence following noise: