aboutsummaryrefslogtreecommitdiffstats
path: root/src/examples/sample-plugin/Makefile.am
diff options
context:
space:
mode:
authorBurt Silverman <burtms@gmail.com>2017-01-27 15:29:54 -0500
committerDave Barach <openvpp@barachs.net>2017-01-28 14:30:26 +0000
commit006eb478bb7a14ba7ba4199fecce29ebc495fb9c (patch)
tree513d2edc2e18d3a998fe5d6e08634f5fa9782ba6 /src/examples/sample-plugin/Makefile.am
parentd4fabb3538f65011893643a62275881a751a4ee8 (diff)
Add files to CLEANFILES for robust make clean.
At the least, $(BUILT_SOURCES) should be added to CLEANFILES. Also beneficial is $(api_DATA), and in the case of Java, *.files and *.h. Also there is a vpp/app/version.h, and some grammar and lex files in vppapigen. Change-Id: Ic6d3f2d40ce65e1d9a8b88217fa1f36de393ebb4 Signed-off-by: Burt Silverman <burtms@gmail.com>
Diffstat (limited to 'src/examples/sample-plugin/Makefile.am')
-rw-r--r--src/examples/sample-plugin/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/examples/sample-plugin/Makefile.am b/src/examples/sample-plugin/Makefile.am
index 47642055..a105afdd 100644
--- a/src/examples/sample-plugin/Makefile.am
+++ b/src/examples/sample-plugin/Makefile.am
@@ -54,3 +54,5 @@ sample_test_plugin_la_SOURCES = sample/sample_test.c sample/sample_plugin.api.h
install-data-hook:
@(cd $(vpppluginsdir) && $(RM) $(vppplugins_LTLIBRARIES))
@(cd $(vppapitestpluginsdir) && $(RM) $(vppapitestplugins_LTLIBRARIES))
+
+CLEANFILES = $(BUILT_SOURCES)