aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/Makefile.am
diff options
context:
space:
mode:
authorBurt Silverman <burtms@gmail.com>2017-01-27 15:29:54 -0500
committerDave Barach <openvpp@barachs.net>2017-01-28 14:30:26 +0000
commit006eb478bb7a14ba7ba4199fecce29ebc495fb9c (patch)
tree513d2edc2e18d3a998fe5d6e08634f5fa9782ba6 /src/plugins/Makefile.am
parentd4fabb3538f65011893643a62275881a751a4ee8 (diff)
Add files to CLEANFILES for robust make clean.
At the least, $(BUILT_SOURCES) should be added to CLEANFILES. Also beneficial is $(api_DATA), and in the case of Java, *.files and *.h. Also there is a vpp/app/version.h, and some grammar and lex files in vppapigen. Change-Id: Ic6d3f2d40ce65e1d9a8b88217fa1f36de393ebb4 Signed-off-by: Burt Silverman <burtms@gmail.com>
Diffstat (limited to 'src/plugins/Makefile.am')
-rw-r--r--src/plugins/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
index f0c455a5..06b575d1 100644
--- a/src/plugins/Makefile.am
+++ b/src/plugins/Makefile.am
@@ -76,3 +76,4 @@ api_DATA = \
BUILT_SOURCES += \
$(patsubst %.api,%.api.h,$(API_FILES))
+CLEANFILES = $(BUILT_SOURCES) $(api_DATA)