aboutsummaryrefslogtreecommitdiffstats
path: root/src/vpp-api/java/Makefile.am
diff options
context:
space:
mode:
authorHongjun Ni <hongjun.ni@intel.com>2017-07-04 20:11:57 +0800
committerNeale Ranns <nranns@cisco.com>2017-08-09 07:41:11 +0000
commit62f9cdd82c52dc05cb89a742d21aba013ce526d4 (patch)
tree76fcde5125faf02ae21724598786e72acc568769 /src/vpp-api/java/Makefile.am
parentf73d0e2ea6bf4e0dc9c69ec4f1d0c7b9b41d2fa3 (diff)
Add PPPoE Plugin
Supports 64K PPPoE sessions This plugin adds three graph nodes: 1) pppoe-input for PPPoE decapsulation 2) pppoe-encap for PPPoE encapsulation 3) pppoe-tap-dispatch for control plane process Below is the configuration to make PPPoE CP and DP work: vim /etc/vpp/startup.conf tuntap { enable ethernet name newtap } create pppoe tap tap-if-index 1 //Configure it after a subscriber's PPPoE discovery and PPP link establishment succeeds: create pppoe session client-ip 100.1.2.1 session-id 1 client-mac 00:11:01:00:00:01 show pppoe fib show pppoe session Change-Id: I73e724b6bf7c3e4181a9914c5752da1fa72d7e60 Signed-off-by: Hongjun Ni <hongjun.ni@intel.com>
Diffstat (limited to 'src/vpp-api/java/Makefile.am')
-rw-r--r--src/vpp-api/java/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/vpp-api/java/Makefile.am b/src/vpp-api/java/Makefile.am
index 4f1f7ed2..e0f5203d 100644
--- a/src/vpp-api/java/Makefile.am
+++ b/src/vpp-api/java/Makefile.am
@@ -149,6 +149,26 @@ jvpp-gtpu/io_fd_vpp_jvpp_gtpu_JVppGtpuImpl.h: $(jvpp_registry_ok) $(jvpp_gtpu_js
endif
#
+# PPPOE Plugin
+#
+if ENABLE_PPPOE_PLUGIN
+noinst_LTLIBRARIES += libjvpp_pppoe.la
+libjvpp_pppoe_la_SOURCES = jvpp-pppoe/jvpp_pppoe.c
+libjvpp_pppoe_la_CPPFLAGS = -Ijvpp-pppoe
+libjvpp_pppoe_la_LIBADD = $(JVPP_LIBS)
+libjvpp_pppoe_la_DEPENDENCIES = libjvpp_common.la
+
+BUILT_SOURCES += jvpp-pppoe/io_fd_vpp_jvpp_pppoe_JVppPppoeImpl.h
+JAR_FILES += jvpp-pppoe-$(PACKAGE_VERSION).jar
+CLEANDIRS += jvpp-pppoe/target
+
+jvpp_pppoe_json_files = @top_builddir@/plugins/pppoe/pppoe.api.json
+
+jvpp-pppoe/io_fd_vpp_jvpp_pppoe_JVppPppoeImpl.h: $(jvpp_registry_ok) $(jvpp_pppoe_json_files)
+ $(call japigen,pppoe,JVppPppoeImpl)
+endif
+
+#
# SNAT Plugin
#
if ENABLE_SNAT_PLUGIN