aboutsummaryrefslogtreecommitdiffstats
path: root/src/vpp-api/python/setup.py
diff options
context:
space:
mode:
authorOle Troan <ot@cisco.com>2017-03-08 12:02:24 +0100
committerOle Troan <ot@cisco.com>2017-03-15 21:43:30 +0100
commit3cc4971882235a539bc6177e8e4b4d92129b3a12 (patch)
treec850b1ea3348da7cd632e782008fbe4e3c6b4c87 /src/vpp-api/python/setup.py
parent9d676afbb779da5186cb3869925ef6d7d3d04db1 (diff)
Python API: Change from cPython to CFFI.
Change-Id: I03e52466fb3f909ae52b8fba601168f3eadbd972 Signed-off-by: Ole Troan <ot@cisco.com>
Diffstat (limited to 'src/vpp-api/python/setup.py')
-rw-r--r--src/vpp-api/python/setup.py15
1 files changed, 5 insertions, 10 deletions
diff --git a/src/vpp-api/python/setup.py b/src/vpp-api/python/setup.py
index 8a34d501..28c2ecce 100644
--- a/src/vpp-api/python/setup.py
+++ b/src/vpp-api/python/setup.py
@@ -13,23 +13,18 @@
# limitations under the License.
try:
- from setuptools import setup, Extension
+ from setuptools import setup
except ImportError:
- from distutils.core import setup, Extension
+ from distutils.core import setup
setup (name = 'vpp_papi',
- version = '1.3',
+ version = '1.4',
description = 'VPP Python binding',
author = 'Ole Troan',
author_email = 'ot@cisco.com',
test_suite = 'tests',
- packages=['vpp_papi'],
- ext_modules = [
- Extension(
- 'vpp_api',
- sources = ['vpp_papi/pneum_wrap.c'],
- libraries = ['pneum'],
- )],
+ install_requires=['cffi'],
+ py_modules=['vpp_papi'],
long_description = '''VPP Python language binding.''',
zip_safe = True,
)