aboutsummaryrefslogtreecommitdiffstats
path: root/vnet/Makefile.am
diff options
context:
space:
mode:
authorTodd Foggoa <tfoggoa@cisco.com>2016-03-17 14:22:34 -0400
committerTodd Foggoa <tfoggoa@cisco.com>2016-03-17 14:23:14 -0400
commit4ea4ecdda9dbc01f9776b63d3a91397b34e46f13 (patch)
treec9ff364cb93d6149c70c40eaae4d6c98693f2db2 /vnet/Makefile.am
parent89b3398a81ab0bcfc891ad78b24dbc8721bbc514 (diff)
Bring back p1.c so plugins can see DPDK symbols
Change-Id: Ia450c9bc6d00fbd054d41a462366f826121d781d Signed-off-by: Todd Foggoa <tfoggoa@cisco.com>
Diffstat (limited to 'vnet/Makefile.am')
-rw-r--r--vnet/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/vnet/Makefile.am b/vnet/Makefile.am
index ff8a31da..c0115eb1 100644
--- a/vnet/Makefile.am
+++ b/vnet/Makefile.am
@@ -16,6 +16,7 @@ AUTOMAKE_OPTIONS = foreign subdir-objects
AM_CFLAGS = -Wall @DPDK@ @VIRL@ @IPSEC@ @VCGN@ @IPV6SR@
libvnet_la_SOURCES =
+libvnetplugin_la_SOURCES =
nobase_include_HEADERS =
noinst_PROGRAMS =
@@ -41,7 +42,6 @@ nobase_include_HEADERS += \
vnet/interface_funcs.h \
vnet/l3_types.h \
vnet/pipeline.h \
- vnet/plugin/plugin.h \
vnet/replication.h \
vnet/rewrite.h \
vnet/vnet.h
@@ -636,7 +636,17 @@ nobase_include_HEADERS += \
vnet/unix/tuntap.h \
vnet/unix/tapcli.h
-lib_LTLIBRARIES = libvnet.la
+########################################
+# Plugin client library
+########################################
+
+libvnetplugin_la_SOURCES += \
+ vnet/plugin/p1.c
+
+nobase_include_HEADERS += \
+ vnet/plugin/plugin.h
+
+lib_LTLIBRARIES = libvnet.la libvnetplugin.la
dpdk_libs =