summaryrefslogtreecommitdiffstats
path: root/vpp/Makefile.am
diff options
context:
space:
mode:
authorDave Barach <dave@barachs.net>2016-05-13 12:55:01 -0400
committerDave Barach <dave@barachs.net>2016-05-21 10:04:06 -0400
commit6931f59e54c9643196c0edda20840e49e9eb1da1 (patch)
treeedc1d340cedcc6aca6b4149fbf96f41e65d61661 /vpp/Makefile.am
parent6f7b992f56955b9eee2f9bd6357e2119645e80f7 (diff)
Add per-thread, per-node runtime stats serialization
Change-Id: Ic4009cdbac67b7cd53c88079439496b9d9dfaa35 Signed-off-by: Dave Barach <dave@barachs.net>
Diffstat (limited to 'vpp/Makefile.am')
-rw-r--r--vpp/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/vpp/Makefile.am b/vpp/Makefile.am
index bd2d30a9..640c844b 100644
--- a/vpp/Makefile.am
+++ b/vpp/Makefile.am
@@ -93,16 +93,20 @@ SUFFIXES = .api.h .api
| vppapigen --input - --output $@ --show-name $@
-noinst_PROGRAMS += test_client test_ha
+noinst_PROGRAMS += test_client
test_client_SOURCES = api/test_client.c
test_client_LDADD = -lvlibmemoryclient -lvlibapi -lsvm -lvppinfra \
-lpthread -lm -lrt
+noinst_PROGRAMS += test_client test_ha
+
test_ha_SOURCES = api/test_ha.c
test_ha_LDADD = -lvlibmemoryclient -lvlibapi -lsvmdb -lsvm -lvppinfra \
-lpthread -lm -lrt
+
+
noinst_PROGRAMS += summary_stats_client
summary_stats_client_SOURCES = api/summary_stats_client.c