aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/configure.ac')
-rw-r--r--plugins/configure.ac57
1 files changed, 57 insertions, 0 deletions
diff --git a/plugins/configure.ac b/plugins/configure.ac
index bf01aacb..40c0babd 100644
--- a/plugins/configure.ac
+++ b/plugins/configure.ac
@@ -20,4 +20,61 @@ AC_ARG_WITH(plugin-toolkit,
AC_SUBST(TOOLKIT_INCLUDE,[${with_plugin_toolkit}])
AM_CONDITIONAL(WITH_PLUGIN_TOOLKIT, test "$with_plugin_toolkit" != ".")
AM_CONDITIONAL(ENABLE_TESTS, test "$enable_tests" = "1")
+
+#
+# Sample plugin
+#
+AC_ARG_ENABLE(sample_plugin,
+ AC_HELP_STRING([--enable-sample-plugin], [Build sample plugin]),
+ [enable_sample_plugin=1],
+ [enable_sample_plugin=0])
+
+if test "x$enable_sample_plugin" = x1; then
+ AC_CONFIG_SUBDIRS([sample-plugin])
+fi
+
+AM_CONDITIONAL(ENABLE_SAMPLE_PLUGIN, test "$enable_sample_plugin" = "1")
+
+#
+# SIXRD plugin
+#
+AC_ARG_ENABLE(sixrd_plugin,
+ AC_HELP_STRING([--enable-sixrd-plugin], [Build sixrd plugin]),
+ [],
+ [enable_sixrd_plugin=1])
+
+if test "x$enable_sixrd_plugin" = x1; then
+ AC_CONFIG_SUBDIRS([sixrd-plugin])
+fi
+
+AM_CONDITIONAL(ENABLE_SIXRD_PLUGIN, test "$enable_sixrd_plugin" = "1")
+
+#
+# IOAM plugin
+#
+AC_ARG_ENABLE(ioam_plugin,
+ AC_HELP_STRING([--enable-ioam-plugin], [Build ioam plugin]),
+ [],
+ [enable_ioam_plugin=1])
+
+if test "x$enable_ioam_plugin" = x1; then
+ AC_CONFIG_SUBDIRS([ioam-plugin])
+fi
+
+AM_CONDITIONAL(ENABLE_IOAM_PLUGIN, test "$enable_ioam_plugin" = "1")
+
+#
+# VCGN plugin
+#
+AC_ARG_ENABLE(vcgn_plugin,
+ AC_HELP_STRING([--enable-vcgn-plugin], [Build vcgn plugin]),
+ [enable_vcgn_plugin=1],
+ [enable_vcgn_plugin=0])
+
+if test "x$enable_vcgn_plugin" = x1; then
+ AC_CONFIG_SUBDIRS([vcgn-plugin])
+fi
+
+AM_CONDITIONAL(ENABLE_VCGN_PLUGIN, test "$enable_vcgn_plugin" = "1")
+
AC_OUTPUT([Makefile])