aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 18a41a15..227accc0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -28,6 +28,14 @@ noinst_HEADERS =
dist_bin_SCRIPTS =
lib_LTLIBRARIES =
BUILT_SOURCES =
+install-data-local:
+ @echo "Building vppctl command list..."
+ @DIR_SEARCH="$(srcdir)" ; \
+ DIR_EXCLUDE="examples" ; \
+ GREP_TIME=`time (grep -wIr "\.path = " $$DIR_SEARCH --exclude-dir=$$DIR_EXCLUDE \
+ | cut -d '"' -f2 | sort -u > $(srcdir)/scripts/vppctl-cmd-list) 2>&1` ; \
+ GREP_TIME=`echo $$GREP_TIME | awk '{print $$2}'` ; \
+ echo "Command list built, Time taken: $$GREP_TIME"
###############################################################################
# DPDK