aboutsummaryrefslogtreecommitdiffstats
path: root/vnet/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'vnet/configure.ac')
-rw-r--r--vnet/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/vnet/configure.ac b/vnet/configure.ac
index b46a6787..b4b6723a 100644
--- a/vnet/configure.ac
+++ b/vnet/configure.ac
@@ -32,6 +32,11 @@ AC_ARG_WITH(ipv6sr,
[with_ipv6sr=0],
[with_ipv6sr=1])
+AC_ARG_ENABLE(tests,
+ AC_HELP_STRING([--enable-tests], [Build unit tests]),
+ [enable_tests=1],
+ [enable_tests=0])
+
AM_CONDITIONAL(WITH_DPDK, test "$with_dpdk" = "1")
AC_SUBST(DPDK,[-DDPDK=${with_dpdk}])
@@ -47,4 +52,6 @@ AC_SUBST(VCGN,[-DVCGN=${with_vcgn}])
AM_CONDITIONAL(WITH_IPV6SR, test "$with_ipv6sr" = "1")
AC_SUBST(IPV6SR,[-DIPV6SR=${with_ipv6sr}])
+AM_CONDITIONAL(ENABLE_TESTS, test "$enable_tests" = "1")
+
AC_OUTPUT([Makefile])