summaryrefslogtreecommitdiffstats
path: root/vpp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'vpp/Makefile.am')
-rw-r--r--vpp/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/vpp/Makefile.am b/vpp/Makefile.am
index 5103646c..73e01b79 100644
--- a/vpp/Makefile.am
+++ b/vpp/Makefile.am
@@ -13,7 +13,7 @@
AUTOMAKE_OPTIONS = foreign subdir-objects
-AM_CFLAGS = -Wall @Q_PLATFORM_DEFINE@ @Q_PLATFORM_PLUGPATH@ @DPDK@
+AM_CFLAGS = -Wall @DPDK@ @IPSEC@ @VCGN@ @IPV6SR@
noinst_PROGRAMS =
BUILT_SOURCES =
@@ -75,9 +75,11 @@ if WITH_DPDK
vpp_LDADD += -l:libdpdk.a
endif
-# These go last
+vpp_LDADD += -lvppinfra -lm -lpthread -ldl
-vpp_LDADD += -lvppinfra -lm -lpthread -lcrypto -ldl
+if WITH_IPV6SR
+ vpp_LDADD += -lcrypto
+endif
SUFFIXES = .api.h .api