summaryrefslogtreecommitdiffstats
path: root/vpp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'vpp/Makefile.am')
-rw-r--r--vpp/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/vpp/Makefile.am b/vpp/Makefile.am
index bd2d30a9..640c844b 100644
--- a/vpp/Makefile.am
+++ b/vpp/Makefile.am
@@ -93,16 +93,20 @@ SUFFIXES = .api.h .api
| vppapigen --input - --output $@ --show-name $@
-noinst_PROGRAMS += test_client test_ha
+noinst_PROGRAMS += test_client
test_client_SOURCES = api/test_client.c
test_client_LDADD = -lvlibmemoryclient -lvlibapi -lsvm -lvppinfra \
-lpthread -lm -lrt
+noinst_PROGRAMS += test_client test_ha
+
test_ha_SOURCES = api/test_ha.c
test_ha_LDADD = -lvlibmemoryclient -lvlibapi -lsvmdb -lsvm -lvppinfra \
-lpthread -lm -lrt
+
+
noinst_PROGRAMS += summary_stats_client
summary_stats_client_SOURCES = api/summary_stats_client.c