summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorHongjun Ni <hongjun.ni@intel.com>2019-02-12 07:41:33 +0000
committerGerrit Code Review <gerrit@fd.io>2019-02-12 07:41:33 +0000
commitb883365902b61f42965eab4940da81168ae8105d (patch)
treec48e761e9de5109a16267690851a5342f8e01774 /src/CMakeLists.txt
parent4f19617f0712ff80787944030e3a2523bc742299 (diff)
parent6c5c1362a9993f305925fe5874b463840a729e9a (diff)
Merge "add build-package for sweetcomb" into stable/1901
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 59b93d8..4888114 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -14,7 +14,9 @@
#
cmake_minimum_required(VERSION 2.8)
-project(sysrepo-vpp)
+project(sweetcomb)
+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake")
+
include(GNUInstallDirs)
@@ -33,3 +35,6 @@ set(CMAKE_C_FLAGS_DEBUG "-g -O0")
# add subdirectories
add_subdirectory(scvpp)
add_subdirectory(plugins)
+
+include(Packager)
+make_packages()