summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorHongjun Ni <hongjun.ni@intel.com>2018-11-20 03:35:38 +0800
committerHongjun Ni <hongjun.ni@intel.com>2018-11-20 03:41:08 +0800
commitfd6c6f7c42d148a980030c7535846a4643d8cc9b (patch)
tree42df5fa7198777b4f3f711c0142f6cb0a7e7fea5 /src/CMakeLists.txt
parenta45498c3a487d9fb561c24b2f3df7910fa54c0f8 (diff)
Initial code commit for Sweetcomb project
The initial code is contruted by Cisco and HuachenTel. It supports three key features: 1). Keeps compatible with IETF Yang Model and Honeycomb Yang Model. 2). Supports mulitiple clients to configure VPP simultaneously. 3). Automatically connect to VPP. Change-Id: I3dda4fddb14062e5f113d505c6a7ee64d60c44c0 Signed-off-by: Rastislav Szabo <raszabo@cisco.com> Signed-off-by: Chuanguo Wang <wangchuanguo@huachentel.com> Signed-off-by: Hongjun Ni <hongjun.ni@intel.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..8d31550
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,35 @@
+#
+# Copyright (c) 2016 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+cmake_minimum_required(VERSION 2.8)
+project(sysrepo-vpp)
+
+include(GNUInstallDirs)
+
+# set default build type if not specified by user
+if(NOT CMAKE_BUILD_TYPE)
+ set(CMAKE_BUILD_TYPE debug)
+endif()
+string(TOLOWER "${CMAKE_BUILD_TYPE}" CMAKE_BUILD_TYPE_LOWER)
+
+# set compiler options
+set(CMAKE_EXPORT_COMPILE_COMMANDS 1)
+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -std=gnu99")
+set(CMAKE_C_FLAGS_RELEASE "-DNDEBUG -O2")
+set(CMAKE_C_FLAGS_DEBUG "-g -O0")
+
+# add subdirectories
+add_subdirectory(srvpp)
+add_subdirectory(plugins)