summaryrefslogtreecommitdiffstats
path: root/src/plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorHongjun Ni <hongjun.ni@intel.com>2018-11-27 23:07:20 +0800
committerHongjun Ni <hongjun.ni@intel.com>2018-11-28 00:14:25 +0800
commit63e7bd9f2730b41f236e0b5d3731e6059210c4c4 (patch)
tree9211f9392925fcbd0067a540a6e70310e6810dfe /src/plugins/CMakeLists.txt
parent76c1926491edcc8a650cc3b5eb87e06d1530cabe (diff)
Rework vpp connection based on vapi library
Change-Id: I3b41b4141fd7ef7577f4f2cc9193b9c623a9d6d7 Signed-off-by: Chuanguo Wang <wangchuanguo@huachentel.com> Signed-off-by: Hongjun Ni <hongjun.ni@intel.com>
Diffstat (limited to 'src/plugins/CMakeLists.txt')
-rw-r--r--src/plugins/CMakeLists.txt15
1 files changed, 11 insertions, 4 deletions
diff --git a/src/plugins/CMakeLists.txt b/src/plugins/CMakeLists.txt
index 41915a1..0c39258 100644
--- a/src/plugins/CMakeLists.txt
+++ b/src/plugins/CMakeLists.txt
@@ -18,7 +18,7 @@ project(sysrepo-vpp-plugins)
find_package(PkgConfig)
pkg_check_modules(SYSREPO REQUIRED libsysrepo)
-pkg_check_modules(SRVPP REQUIRED libsrvpp)
+pkg_check_modules(SCVPP REQUIRED libscvpp)
# get sysrepo plugins directory from pkgconfig
if (NOT SR_PLUGINS_DIR)
@@ -31,9 +31,16 @@ if (NOT SR_PLUGINS_DIR)
message(FATAL_ERROR "Cannot get sysrepo plugins directory due to missing pkg-config, set SR_PLUGINS_DIR manually.")
endif()
+# plugins sources
+set(PLUGINS_SOURCES
+ sc_interface.c
+ sc_plugins.c
+)
+
+
# build the source code into shared library
-add_library(vpp-interfaces SHARED vpp-interfaces.c)
-target_link_libraries(vpp-interfaces ${SYSREPO_LIBRARIES} ${SRVPP_LIBRARIES})
+add_library(vpp-plugins SHARED ${PLUGINS_SOURCES})
+target_link_libraries(vpp-plugins ${SYSREPO_LIBRARIES} ${SCVPP_LIBRARIES})
# install the plugin into plugins dir
-install(TARGETS vpp-interfaces DESTINATION ${SR_PLUGINS_DIR})
+install(TARGETS vpp-plugins DESTINATION ${SR_PLUGINS_DIR})