summaryrefslogtreecommitdiffstats
path: root/src/plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrej Kozemcak <andrej.kozemcak@pantheon.tech>2019-02-14 11:53:05 +0100
committerAndrej Kozemcak <andrej.kozemcak@pantheon.tech>2019-02-27 18:11:59 +0100
commitf9393a8c15fbd63b7a0938269afa8a35ddfc4738 (patch)
tree9748cbe8f618bc79a9f5ff2f709c897dd6c830d8 /src/plugins/CMakeLists.txt
parentcbe7f2d51006c91a73b9f593802abf5b6a2d5984 (diff)
Move bapi to scvpp plugin.
Change-Id: I87be68ddad4827d6dfa04aad5ea725efae97157a Signed-off-by: Andrej Kozemcak <andrej.kozemcak@pantheon.tech>
Diffstat (limited to 'src/plugins/CMakeLists.txt')
-rw-r--r--src/plugins/CMakeLists.txt13
1 files changed, 1 insertions, 12 deletions
diff --git a/src/plugins/CMakeLists.txt b/src/plugins/CMakeLists.txt
index 23c120f..a54ebf0 100644
--- a/src/plugins/CMakeLists.txt
+++ b/src/plugins/CMakeLists.txt
@@ -42,16 +42,6 @@ if (NOT SR_PLUGINS_DIR)
message(FATAL_ERROR "Cannot get sysrepo plugins directory due to missing pkg-config, set SR_PLUGINS_DIR manually.")
endif()
-set(BAPI_SRC
- ./bapi/bapi.c
- ./bapi/bapi_interface.c
- ./bapi/bapi_ip.c
-)
-
-add_library(bapi SHARED ${BAPI_SRC})
-target_include_directories(bapi PUBLIC ${VPP_INCLUDE_DIRS} ./bapi)
-target_link_libraries(bapi ${VPP_LIBRARIES})
-
# plugins sources
set(PLUGINS_SOURCES
sc_plugins.c
@@ -64,8 +54,7 @@ set(PLUGINS_SOURCES
# build the source code into shared library
add_library(vpp-plugins SHARED ${PLUGINS_SOURCES})
-target_link_libraries(vpp-plugins ${SYSREPO_LIBRARIES} ${SCVPP_LIBRARIES} bapi)
+target_link_libraries(vpp-plugins ${SYSREPO_LIBRARIES} ${SCVPP_LIBRARIES})
# install the plugin into plugins dir
install(TARGETS vpp-plugins DESTINATION ${SR_PLUGINS_DIR})
-install(TARGETS bapi DESTINATION ${CMAKE_INSTALL_LIBDIR})