aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorYohanPipereau <ypiperea@cisco.com>2019-02-26 11:47:26 +0100
committerYohanPipereau <ypiperea@cisco.com>2019-02-28 11:56:29 +0100
commit793682e6fcb9e39891c59c696e5f8e9c18f9d8e7 (patch)
tree3c85ee82ab556d696dc7af8a6d9f55e9a08cf7f8 /src/plugins/CMakeLists.txt
parentf9393a8c15fbd63b7a0938269afa8a35ddfc4738 (diff)
This commit changes the way models are registered.
Registering a new model is now done using model_register function which is generic enough to take care of every model family (IETF, Openconfig, ...). Every model (ex: openconfig-interfaces) contain one or several xpaths. Every model (ex: openconfig-interfaces) has its own dedicated C file (ex: openconfig-interfaces.c) with its dedicated xpath_t structure in it. This structure is a mapping of all xpaths of a model to their associated callbacks. It still contains all informations needed by sr_*_subscribe functions. Thus, xpath_t is an external array used in every model, it is seen as a global symbol in shared library. And because these external arrays are passed as arguments to a function, maccros defining the size of these xpath_t arrays have been defined. datastore_e datastructure has been removed to rely on the one provided by sysrepo API. The subscription linked list which was used has been removed because sysrepo already takes care of this. Now, the same subscription_session_ctx_t is used for all subscriptions as it was the case in ietf_subscribe_events. Thus cleanup callback has been simplified to a simple sysrepo_unsubscribe instead of going through the entire Linked List. Change-Id: I43d52f619be27b6216bb3b9d197518b032306fa7 Signed-off-by: Yohan Pipereau <ypiperea@cisco.com>
Diffstat (limited to 'src/plugins/CMakeLists.txt')
-rw-r--r--src/plugins/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/plugins/CMakeLists.txt b/src/plugins/CMakeLists.txt
index a54ebf0..f9bc5ea 100644
--- a/src/plugins/CMakeLists.txt
+++ b/src/plugins/CMakeLists.txt
@@ -45,10 +45,10 @@ endif()
# plugins sources
set(PLUGINS_SOURCES
sc_plugins.c
+ sc_model.c
ietf/ietf_interface.c
openconfig/openconfig_interfaces.c
openconfig/openconfig_local_routing.c
- openconfig/openconfig_plugin.c
openconfig/sys_util.c
)