aboutsummaryrefslogtreecommitdiffstats
path: root/src/scvpp/src/CMakeLists.txt
diff options
context:
space:
mode:
authorYohanPipereau <ypiperea@cisco.com>2019-02-28 17:21:51 +0100
committerYohanPipereau <ypiperea@cisco.com>2019-03-05 16:36:48 +0100
commit3430b042873f2eac94acd323125eaaa4a5f7f3e9 (patch)
tree45335d45b94259f53426413bc5333a36dcfb8f07 /src/scvpp/src/CMakeLists.txt
parent793682e6fcb9e39891c59c696e5f8e9c18f9d8e7 (diff)
Merge IETF and Openconfig to use SCVPP
scvpp should eventually be the only interface with VAPI and should not depend on sysrepo. -All sysrepo error codes in scvpp codes have been changed for errno error codes. scvpp might eventually needs its own error codes. -All log messages in scvpp have been removed as error codes are the only way of reporting failures in a library. -Move VAPI symbol definition to SCVPP. In scvpp, unused maccros SC_VPP_VAPI_RECV and SC_REGISTER_RPC_EVT_HANDLER have been removed. Regarding plugins update: -Use Openconfig way to convert interface name to interface index. -Use Openconfig way to enable/disable an interface. -Use Openconfig way of configuring interface IPs but use more arguments like IETF. -Use Openconfig way of adding a new route. -Use Openconfig way of dumping an IP. -Use common interface dump operation for get_name and get_id. -Delete unused create loopback Change-Id: Icc513a064a2528c2b4cbda2b0dd57755a3b08ef9 Signed-off-by: Yohan Pipereau <ypiperea@cisco.com>
Diffstat (limited to 'src/scvpp/src/CMakeLists.txt')
-rw-r--r--src/scvpp/src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/scvpp/src/CMakeLists.txt b/src/scvpp/src/CMakeLists.txt
index c2a2c40..baa03ed 100644
--- a/src/scvpp/src/CMakeLists.txt
+++ b/src/scvpp/src/CMakeLists.txt
@@ -32,7 +32,7 @@ set(SCVPP_HEADERS
set(CMAKE_C_FLAGS " -g -O0 -fpic -fPIC -std=gnu99 -Wl,-rpath-link=/usr/lib")
# libraries to link with
-set(LINK_LIBRARIES sysrepo vlibmemoryclient vapiclient vppapiclient svm vppinfra pthread rt dl)
+set(LINK_LIBRARIES vlibmemoryclient vapiclient vppapiclient svm vppinfra pthread rt dl)
# build instructions
add_library(scvpp SHARED ${SCVPP_SOURCES})