aboutsummaryrefslogtreecommitdiffstats
path: root/src/scvpp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/scvpp/CMakeLists.txt')
-rw-r--r--src/scvpp/CMakeLists.txt66
1 files changed, 56 insertions, 10 deletions
diff --git a/src/scvpp/CMakeLists.txt b/src/scvpp/CMakeLists.txt
index 2dc42d6..8d04085 100644
--- a/src/scvpp/CMakeLists.txt
+++ b/src/scvpp/CMakeLists.txt
@@ -16,8 +16,57 @@
cmake_minimum_required(VERSION 2.8)
project(scvpp)
-# DEPENDENCIES
-##############
+# COMPILER & LINKER
+###################
+
+# scvpp sources
+set(SCVPP_SOURCES
+ src/comm.c
+ src/interface.c
+ src/ip.c
+ src/v3po.c
+ src/nat.c
+)
+
+# scvpp public headers
+set(SCVPP_HEADERS
+ inc/scvpp/comm.h
+ inc/scvpp/interface.h
+ inc/scvpp/ip.h
+ inc/scvpp/v3po.h
+ inc/scvpp/nat.h
+)
+
+#define CMAKE_INSTALL_LIBDIR/INCLUDEDIR
+include(GNUInstallDirs)
+
+# Generate a compile_commands.json with compile options
+set(CMAKE_EXPORT_COMPILE_COMMANDS 1)
+
+#set compiler and linker flags
+set(RIGOROUS_C_FLAGS "-Wlogical-op -Wformat=2")
+set(CMAKE_C_FLAGS "-Wall -Wextra -std=gnu99 ${RIGOROUS_C_FLAGS}")
+set(CMAKE_C_FLAGS_DEBUG "-Wall -Wextra -std=gnu99 -g -O0 ${RIGOROUS_C_FLAGS}")
+#NDEBUG to skip assert checks
+set(CMAKE_C_FLAGS_RELEASE "-Wall -Wextra -std=gnu99 -DNDEBUG -O2 ${RIGOROUS_C_FLAGS}")
+
+# libraries to link with
+set(LINK_LIBRARIES vlibmemoryclient vapiclient vppapiclient svm vppinfra pthread rt dl)
+
+# build instructions
+add_library(scvpp SHARED ${SCVPP_SOURCES})
+add_library(scvpp_a ${SCVPP_SOURCES})
+
+# linker instructions
+target_link_libraries(scvpp ${LINK_LIBRARIES})
+target_link_libraries(scvpp_a ${LINK_LIBRARIES})
+
+# to build shared and static library for scvpp, include project private directory inc before installing header file
+target_include_directories(scvpp PRIVATE inc)
+target_include_directories(scvpp_a PRIVATE inc)
+
+# TESTING
+#########
# enable testing if requested and possible
SET(ENABLE_TESTS 1 CACHE BOOL "Enable unit tests.")
@@ -32,16 +81,13 @@ if(ENABLE_TESTS)
endif(CMOCKA_FOUND)
endif(ENABLE_TESTS)
-# COMPILER & LINKER & INSTALL
-#############################
-
-#define CMAKE_INSTALL_LIBDIR/INCLUDEDIR
-include(GNUInstallDirs)
-add_subdirectory(src)
+# INSTALL
+#########
-# MORE INSTALL
-##############
+# install rules
+install(TARGETS scvpp DESTINATION ${CMAKE_INSTALL_LIBDIR})
+install(FILES ${SCVPP_HEADERS} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/scvpp)
find_package(PkgConfig QUIET) #QUIET disables message if not found
if(PKG_CONFIG_FOUND)