summaryrefslogtreecommitdiffstats
path: root/external_libs/yaml-cpp/test/CMakeLists.txt
diff options
context:
space:
mode:
authorHanoh Haim <hhaim@cisco.com>2015-08-26 15:50:06 +0300
committerHanoh Haim <hhaim@cisco.com>2015-08-26 15:50:06 +0300
commit53f0e28d7f30c7175cbb15884c309613593859d8 (patch)
treee75ff499233519baa6c50c60fa0c726da7b42e03 /external_libs/yaml-cpp/test/CMakeLists.txt
parenta628a35b10fbd38211c353f506a8c49c2cc3dd7e (diff)
parent00d6f001971b324bb9c884aaf0384a4cee076550 (diff)
Merge branch 'lib_fix'
Diffstat (limited to 'external_libs/yaml-cpp/test/CMakeLists.txt')
-rw-r--r--external_libs/yaml-cpp/test/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/external_libs/yaml-cpp/test/CMakeLists.txt b/external_libs/yaml-cpp/test/CMakeLists.txt
new file mode 100644
index 00000000..241c19ef
--- /dev/null
+++ b/external_libs/yaml-cpp/test/CMakeLists.txt
@@ -0,0 +1,15 @@
+file(GLOB test_headers [a-z]*.h)
+file(GLOB test_sources [a-z]*.cpp)
+file(GLOB test_old_api_sources old-api/[a-z]*.cpp)
+
+list(APPEND test_sources ${test_old_api_sources})
+
+include_directories(${YAML_CPP_SOURCE_DIR}/test)
+
+add_executable(run-tests
+ ${test_sources}
+ ${test_headers}
+)
+target_link_libraries(run-tests yaml-cpp)
+
+add_test(yaml-reader-test run-tests)