summaryrefslogtreecommitdiffstats
path: root/external_libs/python/PyYAML-3.01/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'external_libs/python/PyYAML-3.01/setup.py')
-rw-r--r--external_libs/python/PyYAML-3.01/setup.py52
1 files changed, 0 insertions, 52 deletions
diff --git a/external_libs/python/PyYAML-3.01/setup.py b/external_libs/python/PyYAML-3.01/setup.py
deleted file mode 100644
index 23c1efac..00000000
--- a/external_libs/python/PyYAML-3.01/setup.py
+++ /dev/null
@@ -1,52 +0,0 @@
-
-NAME = 'PyYAML'
-VERSION = '3.01'
-DESCRIPTION = "YAML parser and emitter for Python"
-LONG_DESCRIPTION = """\
-YAML is a data serialization format designed for human readability and
-interaction with scripting languages. PyYAML is a YAML parser and
-emitter for Python.
-
-PyYAML features a complete YAML 1.1 parser, Unicode support, pickle
-support, capable extension API, and sensible error messages. PyYAML
-supports standard YAML tags and provides Python-specific tags that allow
-to represent an arbitrary Python object.
-
-PyYAML is applicable for a broad range of tasks from complex
-configuration files to object serialization and persistance."""
-AUTHOR = "Kirill Simonov"
-AUTHOR_EMAIL = 'xi@resolvent.net'
-LICENSE = "MIT"
-PLATFORMS = "Any"
-URL = "http://pyyaml.org/wiki/PyYAML"
-DOWNLOAD_URL = "http://pyyaml.org/download/pyyaml/%s-%s.tar.gz" % (NAME, VERSION)
-CLASSIFIERS = [
- "Development Status :: 4 - Beta",
- "Intended Audience :: Developers",
- "License :: OSI Approved :: MIT License",
- "Operating System :: OS Independent",
- "Programming Language :: Python",
- "Topic :: Software Development :: Libraries :: Python Modules",
- "Topic :: Text Processing :: Markup",
-]
-
-
-from distutils.core import setup
-
-setup(
- name=NAME,
- version=VERSION,
- description=DESCRIPTION,
- long_description=LONG_DESCRIPTION,
- author=AUTHOR,
- author_email=AUTHOR_EMAIL,
- license=LICENSE,
- platforms=PLATFORMS,
- url=URL,
- download_url=DOWNLOAD_URL,
- classifiers=CLASSIFIERS,
-
- package_dir={'': 'lib'},
- packages=['yaml'],
-)
-