aboutsummaryrefslogtreecommitdiffstats
path: root/cicn-plugin/configure.ac
diff options
context:
space:
mode:
authorJim Gibson <gibson@cisco.com>2017-02-20 11:53:54 -0500
committerJim Gibson <gibson@cisco.com>2017-02-20 12:21:12 -0500
commitdfd7ce27fea04c1a76844e21286c2b1d6653e153 (patch)
tree0025f965ddb68599ea824b9d9edf61b7647dd4ec /cicn-plugin/configure.ac
parent9b30fc10fb1cbebe651e5a107e8ca5b24de54675 (diff)
Initial Commit: VPP cicn VPP plugin
Change-Id: If1b965f0a4b7cfacda8f6caf6925072a9007ffb4 Signed-off-by: Jim Gibson <gibson@cisco.com>
Diffstat (limited to 'cicn-plugin/configure.ac')
-rw-r--r--cicn-plugin/configure.ac33
1 files changed, 33 insertions, 0 deletions
diff --git a/cicn-plugin/configure.ac b/cicn-plugin/configure.ac
new file mode 100644
index 00000000..a1477f8a
--- /dev/null
+++ b/cicn-plugin/configure.ac
@@ -0,0 +1,33 @@
+
+AC_INIT(cicn_plugin, 1.0)
+AM_INIT_AUTOMAKE
+
+AC_PROG_LIBTOOL
+AM_PROG_AS
+AC_PROG_CC
+AM_PROG_CC_C_O
+
+# always give this switch, should be hard-wired(?)
+# ../configure ... --with-plugin-toolkit
+AC_ARG_WITH(plugin-toolkit,
+ AC_HELP_STRING([--with-plugin-toolkit],
+ [build using the vpp toolkit]),
+ [with_plugin_toolkit=${prefix}/include],
+ [with_plugin_toolkit=.])
+
+AC_SUBST(TOOLKIT_INCLUDE,[${with_plugin_toolkit}])
+AM_CONDITIONAL(WITH_PLUGIN_TOOLKIT, test "$with_plugin_toolkit" != ".")
+
+# control build inclusion of cicn UT modules
+# include: <default>
+# omit: ../configure ... --without-cicn-test
+AC_ARG_WITH(cicn-test,
+ AC_HELP_STRING([--without-cicn-test],
+ [disable support for cicn-test]),
+ [],
+ [with_cicn_test=yes])
+
+AC_SUBST(TOOLKIT_INCLUDE,[${with_cicn_test}])
+AM_CONDITIONAL(WITH_CICN_TEST, test "x$with_cicn_test" != x"no")
+
+AC_OUTPUT([Makefile])