aboutsummaryrefslogtreecommitdiffstats
path: root/libparc/parc/logging/test/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Papalini <micpapal+fdio@cisco.com>2017-02-24 08:00:33 +0000
committerGerrit Code Review <gerrit@fd.io>2017-02-24 08:00:33 +0000
commit4df7f4cc98b6288177df256e1db70ddc3f7d00db (patch)
tree55e71277b419e4830ae641868ab8e751c8b86972 /libparc/parc/logging/test/CMakeLists.txt
parentf28308bd99381ef5f1e178e2e1f870f245e35873 (diff)
parentec688b4723a041044226358bcd4dd6e2da39da49 (diff)
Merge "Initial commit: cframework. Longbow and Libparc" into cframework/master
Diffstat (limited to 'libparc/parc/logging/test/CMakeLists.txt')
-rw-r--r--libparc/parc/logging/test/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/libparc/parc/logging/test/CMakeLists.txt b/libparc/parc/logging/test/CMakeLists.txt
new file mode 100644
index 00000000..060a0ba1
--- /dev/null
+++ b/libparc/parc/logging/test/CMakeLists.txt
@@ -0,0 +1,20 @@
+set(TestsExpectedToPass
+ test_parc_Log
+ test_parc_LogEntry
+ test_parc_LogFormatSyslog
+ test_parc_LogFormatText
+ test_parc_LogLevel
+ test_parc_LogReporter
+ test_parc_LogReporterFile
+ test_parc_LogReporterTextStdout
+ )
+
+# Enable gcov output for the tests
+add_definitions(--coverage)
+set(CMAKE_EXE_LINKER_FLAGS ${CMAKE_EXE_LINKER_FLAGS} " --coverage")
+
+foreach(test ${TestsExpectedToPass})
+ AddTest(${test})
+endforeach()
+
+